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Problem Note 60056: The SAS® Deployment Backup and Recovery Tool might report that the database for a solution data server was recovered successfully when it was not

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Problem

When you use the Deployment Backup and Recovery Tool batch command sas-recover-offline, recovery of a SAS® solution data server might be incorrectly reported as successful. In this scenario, the tool reports success even if it was unable to connect to the data server to perform a recovery.

When this problem occurs, sas-recover-offline reports the recovery for the sourceType DATABASE as successful. Here is an example:

type:   Recovery
        status: SUCCES
        backupSources
                sourceType:     DATABASE
                status: SUCCESS

But, when you examine the SAS-configuration-directory\Levn\Backup\backupserver.log file, you find a message that says the connection to the database for the restore was refused. Here is an example:

INFO  com.sas.svcs.backup.server.handler.PostgresRecoveryHandler - pg_restore:Connecting to database for restore
INFO  com.sas.svcs.backup.server.handler.PostgresRecoveryHandler - pg_restore: [archiver (db)] connection to database "databaseName" failed: could not connect to server: Connection refused (0x0000274D/10061)
INFO  com.sas.svcs.backup.server.handler.PostgresRecoveryHandler -  Is the server running on host yourhost.yourdomain.com (your IP address) and accepting TCP/IP connections on port 5432?

Cause

This problem might occur if you did not start the solution data server before executing sas-recover-offline. If the solution data server is not running, then the Deployment Backup and Recovery Tool is not able to connect to the solution data server. However, the tool does not report this as a failure for the database recovery. 

Solution

A fix for this issue is planned for a future release of SAS software. 

If you encounter this problem, stop all servers and services except the SAS® Metadata Server, SAS® Web Infrastructure Platform Data Server (including any solution data servers), and the SAS® Deployment Agent. Then, run sas-recover-offline a second time. 

To read about the steps for performing a recovery using the Deployment Backup and Recovery Tool, see the SAS Intelligence Platform Batch Tools: Reference of the SAS® 9.4 Intelligence Platform: System Administration Guide, Fourth Edition.



Operating System and Release Information

Product FamilyProductSystemProduct ReleaseSAS Release
ReportedFixed*ReportedFixed*
SAS SystemSAS Deployment Backup and Recovery ToolSolaris for x649.429.449.4 TS1M49.4 TS1M6
Linux for x649.429.449.4 TS1M49.4 TS1M6
HP-UX IPF9.429.449.4 TS1M49.4 TS1M6
64-bit Enabled Solaris9.429.449.4 TS1M49.4 TS1M6
64-bit Enabled AIX9.429.449.4 TS1M49.4 TS1M6
Microsoft® Windows® for x649.429.449.4 TS1M49.4 TS1M6
z/OS9.429.449.4 TS1M49.4 TS1M6
* For software releases that are not yet generally available, the Fixed Release is the software release in which the problem is planned to be fixed.